Pegasus: Basic Troubleshooting



As technology progresses, our daily life is getting more complicated. The devices we use are also getting more complicated and when things go wrong, the often unanswered question is, how do I fix this? This guide show you the steps to troubleshooting Pegasus issues.


Troubleshooting Steps

The following items should be checked in the order given.

  1. Power
  2. Thunderbolt connection
  3. Driver
  4. Disk Utility
  5. Filesystem



Verify that the Pegasus powers on.

The  Pegasus 1 (Thunderbolt 1) and the Pegasus 2 (Thunderbolt 2) will power on when the power cable is plugged in.

The Pegasus 3 (Thunderbolt 3) and Pegasus 32 (Thunderbolt 3) will power on only when both the power cable is plugged in and the Pegasus Thunderbolt port is connected to an operating Mac or Windows Thunderbolt port.

Perhaps the most common reason for a Pegasus to not power on is a bad or intermittant Thunderbolt cable, the first thing to check is the Thunderbolt cable, try another (ideally known working) cable.

If after replacing the Thunderbolt cable the Pegasus still does not power up, it might help to leave the Thunderbolt cable plugged in and to remove the power cable for about 1 minute and plug it back in again.

Also, users with a UPS sometimes see that the Pegasus won't power on. Often the UPS is very old and it can't deliver enough voltage. Or it may be oversubscribed, that is, have too many devices attached and can't provide enough power for all of them. Either way, the simplest way to check is to unplug the Pegasus from the UPS and connect it to a wall socket.


Thunderbolt connection

Make sure there is a connection to the computer's Thunderbolt bus.

To check, get a System Report and check under the Thunderbolt section.

If the Pegasus does not show in the Thunderbolt section, then the Mac cannot see it.

In this case, even if the Pegasus powers on, the Thunderbolt cable is suspect.

Some common reasons why there might be no Thunderbolt connection are...

  1. The Thunderbolt cable is plugged into a USB3 port. Most windows computers have no Thunderbolt port, and many Macs have USB only ports. For example the two front ports in a Studio Max are USB only.
  2. There may be issues with the Thunderbolt 3 > Thunderbolt 2 adapter needed when connecting a Pegasus 1 or Pegasus 2 to a modern Mac. The Apple converter works well and there have been no connection issues with them. Some other manufacturers adapters have not worked with the Pegasus.



Intel macOS has a Pegasus driver builtin. But with the M1 macOS, a driver needs to be installed.

Follow this guide to correctly install the DEXT driver.

For Intel macOS, on occasion after an update, the Pegasus kext driver won't load for some reason. To check if this is the case, use this command.

promise@promises-Mac-mini-2 ~ % kextstat | grep promise
Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release
promise@promises-Mac-mini-2 ~ %

From the above the STEX driver is not loaded.

To manually load the builtin STEX driver...

promise@promises-Mac-mini-2 ~ % sudo kextload /System/Library/Extensions/PromiseSTEX.kext
Executing: /usr/bin/kmutil load -p /System/Library/Extensions/PromiseSTEX.kext
promise@promises-Mac-mini-2 ~ %

There are no errors, the driver load succeedded. To verify...

promise@promises-Mac-mini-2 ~ % kextstat | grep promise
Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release
  194    0 0xffffff8003473000 0xb000     0xb000     com.promise.driver.stex (6.2.13) AE253556-66D8-38D2-B9D1-179B78F29153 <191 16 7 6 3>
promise@promises-Mac-mini-2 ~ %

The Pegasus STEX driver, v6.2.13 is now loaded.


Disk Utility

If the Pegasus powers up, shows in the Thunderbolt section of the System Report, the correct driver is loaded, but the Volume still does not mount, check Disk Utility. If the Pegasus disk does not show, try reseating the Thunderbolt cable. After reconnecting the Thunderbolt cable, it may take 1 or 2 minutes for the LUN to show in Disk Utility. Once Disk Utility sees the disk, the Volume should mount.



If the Volume shows in Disk Utility but does not mount, there may be issues with the filesystem.

First step, use the Disk Utility mount option.

If the mount option fails, try First Aid. First Aid is useful and will often work, but occasionally it does not work. Some 3rd party recovery tools are available. Promise does not endorse any company or tool, but for many years the goto tool for this kind of problem has been Disk Warrior. Be advised that this is not a free tool.

If software tools are ineffective, there are various data recovery services. A quick google will show any in your local area as well as non-local companies. Be advised that data recovery is not inexpensive.



This KB gives the basic procedure for troubleshooting Pegasus issues. Most issues can be solved by following this procedure. For those where there is filesystem damage, there are 3rd party tools and data recovery companies that can help.