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Chapter 1: Introduction
• Overview (page 1)
• Terminology (page 1)

Overview
The Promise recovery agents offer recovery solutions for your database and messaging systems.
• Message Recovery for Microsoft® Exchange (MRME) – Expedites mailbox and message recovery by enabling you to 

quickly recover individual mailboxes from point-in-time snapshot images of their messaging server.
• Database Recovery for Microsoft SQL Server (DRMSS) – Expedites database recovery by enabling you to quickly recover 

a database from point-in-time snapshot images of their SQL database.
• Recovery Agent for Microsoft Volume Shadow-Copy Service (VSS) – Enables you to restore volumes and volume groups 

from point-in-time snapshots created by the Snapshot Agent for Microsoft VSS.

Terminology

Checksum
A checksum verifies whether a messaging system, database, or file system was successfully quiesced and whether snapshot data 
was correctly written.

Group
Also referred to as Snapshot Group. Building on the snapshot technology, disks can be grouped into a group for snapshot 
synchronization purposes. Snapshots for all resources in a group are taken at the same time whenever a snapshot is triggered. It 
is recommended that you have your database and logs on separate disks. Putting them into a single group allows a snapshot to 
be taken of all resources at the same time.

Integrity
An integrity check sweeps snapshot data for errors. An integrity check is more comprehensive than a checksum and takes longer 
to complete.

IMA
Intelligent Management Agent (IMA) is a software module that resides on the host machine and provides core services such as 
authentication, encryption, and management functions to host agents. 

MRME
Message Recovery for Microsoft Exchange (MRME) works with VTrak S3000 Server to protect and recover Exchange databases 
that are stored on a VTrak S3000 Server-managed disk. 

RDB
A recovery database (RDB) is a unique type of mailbox database that allows you to mount a restored mailbox database and 
extract data from the restored database as part of a recovery operation.

SAN Disk Manager
SAN Disk Manager resides on host machines and provides core services such as authentication, encryption, and management 
functions. 

Scripts
Scripts define the disks and devices that are mapped to the Application host machine from a storage server that are included in 
each snapshot.
1
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Snapshot
A Snapshot is a point-in-time image of any virtual disk or data volume. Using Promise Snapshot technology, Snapshots track 
multiple virtual images of the same disk marked by time. If you need to retrieve a deleted file or undo data corruption, you can 
recreate and restore the file instantly based on any of the existing Snapshots. Each Snapshot represents one backup image. 

Snapshot Agent
The Snapshot Agent for each recovery tool ensures transactional consistency and reliability.
• Snapshot Agent for Microsoft SQL creates Snapshots to ensure database and application system data integrity.
• Snapshot Agent for Microsoft Exchange ensures transactional integrity by notifying the Exchange Server to quiet activity on 

the disk before a snapshot is taken.
• Snapshot Agent for VSS protects VSS-aware drives with full point-in-time consistency while still allowing non-stop access to 

the data.

SnapshotView
A SnapshotView, also known as a backup image, is a mountable Snapshot. It allows you to access files and directories by 
mounting a virtual drive as of a specific point-in-time, based on existing Snapshots. 

VSS
Microsoft Volume Shadow-Copy Service (VSS) provides the backup infrastructure for Microsoft Windows operating systems, 
using a set of extensible application programming interfaces (APIs) to create consistent point-in-time copies of data, or shadow 
copies, across multiple volumes, regardless of the snapshot technology or application, by coordinating with business applications, 
file-system services, backup applications, fast recovery solutions, and storage hardware.

The Recovery Agent for Microsoft VSS enables IT administrators to restore volumes and volume groups from point-in-time 
snapshots created by the Snapshot Agent for Microsoft VSS.
2



Chapter 2: Message Recovery for Microsoft Exchange (MRME)
• Context Sensitive Restore (page 3)
• New with Exchange 2010 (page 3)
• General Requirements (page 4)
• Installing the Software (page 4)
• Storage Servers (page 5)
• Recovery Procedure on Microsoft Exchange 2010 (page 5)
• Recovery Procedure on Microsoft Exchange 2007 (page 10)
• Making Global Settings (page 14)
• Advanced Features using Version 4.0 (page 16)

Promise Message Recovery for Microsoft Exchange (MRME) works with VTrak S3000 Server to protect and recover Exchange 
mailboxes that are stored on VTrak S3000 Server-managed disks. VTrak S3000 Server and Snapshot work in conjunction with the 
Snapshot Agent for Microsoft Exchange to take point-in-time snapshot images of the Exchange databases that are stored on a 
VTrak S3000 Server-managed disk. The Snapshot Agent gives the Snapshot images point-in-time consistency and transactional 
integrity.

Message Recovery for Microsoft Exchange (MRME) version 4.0 gives you a choice of two 
interfaces. The new Microsoft Management Console (MMC) user interface supports Exchange 
2010 and 2007. 

The MRME 4.0 interface displays Exchange Servers, Mailbox Databases, and storage servers 
along with their status in the navigation tree. This allows you to see any unmounted mailbox 
databases at a glance.

The MRME version 3.0 interface also installs with support for Exchange 2007 and 2003.

Context Sensitive Restore
If you select the new MMC interface for Exchange, you can use the context sensitive restore feature. This allows you to select an 
Exchange Server, Exchange Mailbox Database (DB), or Exchange mailboxes. Right-click your selection and run the restore 
wizard. The restore wizard launches in context to your selection. For example, if you right-click a mailbox, the restore wizard has 
the Exchange Server, Exchange Mailbox DB, and Exchange Mailbox pre-selected on the screen. You simply verify and click the 
Next button, select your filters, and click the Finish button.

New with Exchange 2010
With Exchange 2010, storage groups no longer exist. If you need to restore, recover, and mount an Exchange database, you must 
use a Recovery Database (RDB). With Exchange Server 2010, the administrator can restore data directly to a recovery database. 
Mounting the recovered data as a recovery database allows the administrator to restore individual mailboxes or individual items in 
a mailbox. You can have multiple RDBs but an Exchange 2010 server can only mount one RDB at a time. 
3
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With Exchange 2007 and 2010, email can be recovered from any Recovery Storage Group (RSG) or RDB. There is no need to 
use Exchange system tools to create an RSG or mailbox merge as with earlier versions.

MRME enables administrators to mount the storage server’s Snapshot images so that mailboxes can be easily and quickly 
recovered from any protected Exchange Server in the same Exchange Administrative Group.

The recovery procedure varies depending upon which version of Microsoft Exchange you use. See:
• “Recovery Procedure on Microsoft Exchange 2010” on page 5
• “Recovery Procedure on Microsoft Exchange 2007” on page 10

General Requirements
Your Microsoft Exchange Server must have a VTrak S3000 Server SAN Client or SAN Disk Manager, Intelligent Management 
Agent (SDM/IMA) installed.
• Exchange 2010 – Snapshot Agent for VSS required.
• Exchange 2007 – Snapshot Agent for VSS OR Snapshot Agent for Exchange AND File System Agent.

For Microsoft Exchange 2007, Promise recommends:
• A minimum of two disks, one for the database and one for the logs.
• A maximum of three disks or LUNs for the Exchange database and logs.
• The Exchange Database (EDB) and Streaming Media (STM) database files must be on the same disk or LUN.
• Log files and system files should be on a single disk or LUN to expedite the recovery process.
• If you must keep the database files and log files on one disk, the log files and system directory must be in either of the 

following locations:
• The first partition on the disk
• A unique sub-directory of a partition other than the first partition.

Installing the Software
Installation of MRME has the following requirements:
• Before you install MRME you must install Promise SAN Disk Manager (SDM/IMA) on the same computer. If SDM/IMA is not 

detected when recovery agent installation begins, an error message displays. Cancel the procedure, install SDM/IMA, and 
then repeat recovery agent installation.

• MRME must be installed on an Exchange Server.
• You must be the Administrator or have Administrator privileges to install and run this recovery agent.

To install MRME:
1. Launch the installation from the software DVD.
2. Read and accept the license agreement.
4
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3. When prompted, enter your license key code.
The MRME license must be registered with Promise.
• If your computer has an Internet connection, the license is activated as soon as you enter your key code and click the 

Next button. 
• If your Internet connection is temporarily down, your license activates automatically the next time MRME is started and 

your Internet connection is working.
• If your computer has no Internet connection, you must perform an offline activation. See the VTrak S3000 Setup Guide 

for more information.
You have 30 days activate your license so that you can continue to use MRME.

4. When you are done, click the Finish button.

Storage Servers
The first time you start MRME, the system scans and imports all storage servers identified by the SDM/IMA Client. These storage 
servers are listed in the MRME console and must be authenticated.

When you add a storage server directly in SDM/IMA, the storage server is imported into MRME the next time you click the Storage 
Servers node.

To add a storage server:
1. Right-click the Storage Servers node in the Tree and select New Storage Server.
2. Enter the following information:

• Server name – IP address or a resolvable hostname of the storage server.
• User name – Enter the user name that you created for MRME in the Management Console.
• Password – Enter the password that you created for MRME in the Management Console.
• Protocols – Select which protocols your MRME client uses. You must select at least one.

3. Click the OK button.

Recovery Procedure on Microsoft Exchange 2010 
This section describes how to recover messages from Recovery Databases on Microsoft Exchange 2010 using the updated, easy-
to-use wizard. The recovery wizard enables administrators to recover mailboxes from local Exchange 2010 servers and remote 
Exchange 2010 servers that are in the same Exchange Administrative Group.

You must be a local administrator and a full Domain Exchange administrator in order to recover mailboxes. If you want to pre-
configure MRME to launch from a non-Exchange Domain Administrator user, see “LaunchMRMEAsUser Utility on Exchange 2010 
and 2007” on page 8.

Be sure to log into Windows with the same account with which you are doing the recovery.

1. Launch the Message Recovery for Microsoft Exchange Console on the Exchange Server. Go to Start > All Programs > 
SANClient > Message Recovery for Exchange.

2. Right-click a Mailbox Database, a Mailbox, or an Exchange Server and select Action > Restore Email from a Recovery 
Image.
5
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Alternatively, access this option from the main menu. Select Action > Restore Email from a Recovery Image.
This action launches the Recovery wizard that creates and mounts a backup image of the Mailbox store to a local Recovery 
mailbox database, and then restores email.
To restore from a previously mounted recovery database, select Action > Restore Email from a mounted Recovery 
Database.

3. Select the Mailbox Store from the drop-down list and specify a Recovery Mailbox Store Name. 

The specified Recovery Database is created and mounted from the backup images. Click the Next button to continue to the 
Mailbox Email Restore Selections screen.

4. Specify the restore selections.
• The Restore email now option button is selected by default. 
• Select the mailbox to restore from the drop down list. 
• Select whether you want to merge the restored email with your existing email or copy the restored email to a folder. If you 

choose to copy the email to a folder, enter the folder name.
• Depending upon the size of the mailbox, the restore operation can take a while. If you want to see the restore progress, 

check the Show email restore output screen during email restore box. 
• Click Mount the backup image only option button if you plan to use another utility to restore email.

5. Enter the storage server login information,
• Storage Server Name – Select from the drop down list.
• Storage Server Protocol – Select Fibre Channel (FC) or iSCSI.
6
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6. Map the mailbox resources to the storage server LUNs.

7. Select the Snapshot (backup image) from which you want to restore and click the Next button.
7
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8. Once the mailbox has been recovered successfully, click the Finish button.

Cleanup on Microsoft Exchange 2010
Cleanup for Exchange 2010 includes removing the recovery database and the recovery images. To run the cleanup process, 
select Tools > Advanced > Dismount and remove recovery image.

LaunchMRMEAsUser Utility on Exchange 2010 and 2007
The LaunchMRMEAsUser utility allows Exchange Administrators to pre-configure MRME to launch with Exchange Domain rights 
from a lower level login.

Parameters & Options

Caution

When you exit the application, the wizard prompts you to delete the mounted backup images. Make sure to 
verify the recovery before deleting the backup image.

Required Parameters Descriptions

-a[Application] If specified, the named application launches.
If not specified, the default Message Recovery for Microsoft Exchange (MRME) 
application launches.

-x[Application] Clears the saved user credentials for the named Application.
If not specified, the default MRME application user credentials are cleared.
8
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Usage Examples

Optional Parameters Descriptions

-d<Exchange Domain> If specified, the Exchange Domain is used for this run and saved for the next run of the 
specified application. 
If not specified, the previously saved Exchange Domain for the specified application is 
used.

-u<Exchange Domain User> If specified, the Exchange Domain User is used for this run and saved for the next run 
of the specified application. 
If not specified, the previously saved Exchange Domain User for the specified 
application is used.

-p<Exchange Domain User Password> If specified, the Exchange Domain User Password is used for this run, encrypted, and 
saved for the next run of the specified application. 
If not specified, the previously saved Exchange Domain User Password for the 
specified application is used.

-c<Command Arguments> The application is launched with the specified command arguments.

-z Silent mode

-? Help

Command Result

LaunchMRMEAsUser -ammc.exe -c"C:\Program 
Files\Promise\MRME\Message Recovery for Microsoft 
Exchange.msc

Launches the MRME v4.0 UI with the saved Exchange Domain 
User Credentials.

LLauncheMRMEAsUser -x Clears the User Credentials for:
"C:\Program Files <x86> \Promise\MRME\ExRecoverUI.exe"
9
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Recovery Procedure on Microsoft Exchange 2007
This section describes how to recover messages from a Recovery Storage Group (RSG) on Microsoft Exchange 2007 using the 
updated, easy-to-use wizard. The recovery wizard enables administrators to recover mailboxes from local Exchange 2007 servers 
and remote Exchange 2007 servers that are in the same Exchange Administrative Group.

1. Enter the domain and user authentication information needed to log into the Exchange Server and access its Active Directory 
configuration.

• Root Domain Name – Exchange Server domain.
• Domain Server Name – Domain controller for the Active Directory tree. You must enter the server name, not an IP 

address.
• User Name/User Password – This login user must have rights to access and export Exchange Server objects such as, 

Mailbox objects, and Exchange users objects.
• Login User Domain – Domain for the user account specified above.

After logging into Active Directory, a list of Mailbox stores are available for selection as shown below.

2. Select the mailbox store that contains the mailbox that you want to recover.
10
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3. If you have not already created a Recovery Storage Group, click the Create RSG tab.
The Create Recovery Storage Group screen displays.

4. Enter the RSG name.
5. Once the RSG group has been created, click the Next button.

Click the Mount the backup image only option button if you plan to use a different utility to restore email.
The Mailbox Email Restore Selections screen displays.

The Restore email now option button is selected by default. 
6. Select the mailbox to restore from the drop down list. 
7. Select whether you want to merge the restored email with your existing email or copy the restored email to a folder.

If you choose to copy the email to a folder, enter the folder name.
Depending upon the size of the mailbox, the restore operation can take a while. If you would like to see the restore progress, 
check the Show email restore output screen during email restore box. 

8. Select any appropriate options or filters for the email restore.

You can filter by date and by text contained in the email subject or body. Each filter further restricts the email selection.
11
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9. Enter storage server login information.

You need to log into the VTrak S3000 server that contains the Snapshots for the mailboxes to be recovered. This can be a 
primary server or a replica server. 
Indicate which protocol to use:
• Fibre Channel (FC)
• iSCSI
• SAN/IP

10. If you are recovering from a remote Exchange Server, select the snapshot group that contains the mailbox to be recovered 
and select the appropriate SAN Resource used for the storage of each Exchange component.

11. Select the Snapshot from which you want to recover. 
Promise recommends that you select a Snapshot indicated as quiescent.
12
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12. Confirm all information and then click the Finish button to mount the Snapshot to the RSG.

The SnapshotView device or backup image is mounted using the next available drive letters and to mountpoints if you are 
using the Mountpoint feature.
Wait for the SnapshotView to be mounted. It can take a few minutes.
13
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13. Click the Finish button when you see a screen similar to the following:

Cleanup on Microsoft Exchange 2007
Cleanup for Exchange 2007 includes removing the RSG and mounted backup images. The cleanup process occurs automatically 
when you start another recovery or exit the application. To run cleanup manually, select Tools > Advanced > Dismount RSG 
Backup image.

Making Global Settings
Under Global Settings, you can change the Exchange Credentials, the mount point directory, the purge policy and the log settings.

To configure global settings, in the main menu, navigate to Action > Global Settings. Alternately, right-click any node in the Tree 
and select Global Settings in the popup menu.

Exchange Credentials
To perform email message recovery, you must have Exchange Domain Administration-level credentials. Select the Exchange 
Credentials tab and enter the following information:
• Root Domain Name 
• Domain Server Name
• User Name 
• User Password
• Login User Domain
14
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Mounting a Directory
Select the Mount Directory tab to specify the root directory to be used as Backup Image mountpoints during message recovery.

During recovery, you can select when to use mountpoints instead of drive letters.

Setting Purge Policy
Select the Purge Policy tab to specify the MRME Event log purge policy. The selected purge policy options are applied 
immediately and are as follows:
• Purge when there are more than ___ transaction logs per database
• Purge when transaction logs are older than ___ days.

Important

If your transaction log backups are done on a VTrak S3000 server-managed disk, a copy of the transaction 
log backups are maintained in the VTrak S3000 server.
15
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Making Log Settings
To configure the User Log and Trace Log settings:
1. Select the Log Settings tab.
2. From the dropdown menus, select a trace setting for

• User Log 
• Trace Logs.

The User Log records actions, errors, and warnings. You can change the default Medium setting to record more or less 
information.
The Trace log is a diagnostic tool used by the Technical Support team. Each Trace log contains technical information about 
your system as well as system messages. You should not turn the Trace log on unless you are requested to do so by your 
Technical Support representative. 
To turn the Trace Log on, select Options > Trace. 
To view the Trace Log, select View > Log.

Advanced Features using Version 4.0
While most recovery operations can be performed via the Recovery Wizard, advanced features are available for special 
scenarios, For example if you want to recover from two different points in time, you could select a Snapshot from one point in data 
and a log from another point-in-time. In another example, you are using virtual servers and you want to recover from a Snapshot 
that contains a Virtual Hard Disk (VHD) and a VMware Virtual Disk file (VMDC).

From the Action > Advanced menu, you can perform the following:
• Create Recovery Image
• Validate Recovery Image
• Mount Recovery Image to a Recovery Database
• Dismount and remove Recovery Image

Performing a Manual RSG or RDB Recovery
MRME includes an easy-to-use wizard that enables administrators to recover mailboxes from local and remote Exchange 2007 
and 2010 servers. However, there may be advanced configurations that cause the wizard not to detect the logical resources 
containing the Exchange database. For example, if your Exchange system is not connected directly to the storage server that 
contains your backup images, such as a remote replica server, MRME is unable to identify the logical resources and map the 
Snapshots.

For these types of configurations, MRME includes tools that let you manually log into the storage server, manually select 
Snapshots, and manually validate and mount the mailbox store to the RSG or RDB.
16
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To manually create a recovery image:
1. Select Action > Advanced > Create Recovery Image. 
2. If you are recovering from a remote Exchange Server, select the snapshot group that contains the mailbox to be recovered 

and select the appropriate SAN Resource used for the storage of each Exchange component.
3. Select the Snapshot from which you want to recover. 

Promise recommends that you select a Snapshot indicated as quiescent.
4. Confirm all information and then click the Finish button to mount the Snapshot to the RDB.

Validating Recovery Images
To validate a recovery image:
1. Select Action > Advanced > Validate Recovery Image.
2. Specify the database path, the log directory and log file base name for the RSG or RDB.
3. Click the OK button to validate the backup images.

Mounting the Recovery Image to a Recovery Database
To mount a recovery image to a recovery database:

Select Action > Advanced > Mount Recovery Image to a Recovery Database.

Dismounting and Removing a Recovery Image 
Before you recover from a new backup image, you are prompted to delete any existing backup images.

To delete the backup image manually:
Select Action > Advanced > Dismount and remove recovery image.
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Promise Database Recovery for Microsoft SQL Server (DRMSS) expedites database recovery by enabling IT administrators to 
quickly recover a database from point-in-time snapshot images of their SQL database. The recovery method you use depends 
upon the SQL recovery model that your database uses:
• The Full Recovery Model maintains the transaction log history that records all changes to the database. This feature allows 

you to recover to any point in time.
• The Simple Recovery Model only allows you to roll back to the time of a scheduled Snapshot. 
To take full advantage of this recovery application, use the Full Recovery Model on at least one of your databases.

This recovery tool integrates with your VTrak Storage Server to restore snapshot images of the SQL databases that are stored on 
VTrak S3000 Server-managed disks. Promise Snapshots work in conjunction with the Snapshot Agents to take scheduled 
snapshot images of the SQL databases. The Snapshot Agents give the snapshot images point-in-time consistency and 
transactional integrity.

System Requirements
• Database Recovery for Microsoft SQL Server (DRMSS) supports the following systems:

• Microsoft SQL Server 2008 R2, 64-bit. You must use Promise Snapshot Agent for Microsoft VSS.
• Microsoft SQL Server 2008, 32-bit and 64-bit
• Microsoft SQL Server 2005 32-bit and 64-bit
• Microsoft SQL Server 2003 32-bit and 64-bit

• DRMSS must run on the SQL Server machine because certain configuration information is maintained during snapshots. 
Restoring to a different machine is not supported.

• Promise SAN Disk Manager (SDM/IMA) must be installed on the SQL Server.
• Promise recommends that you use three disks for performing transaction log backups, to ensure the fastest possible restore. 

Use a separate disk for each of the following items:
• Database
• Transaction log
• Transaction log backups

• Snapshot must be enabled on your storage server. To recover your database with as much granularity as possible, configure 
Snapshot to regularly take point-in-time images of your server.

• The Snapshot Agent for Microsoft SQL Server and the Snapshot Agent for Windows file systems must be installed.
• In the storage server console, you must create a group for your SQL database, log, and backups. The group name cannot 

contain any spaces.
• Snapshot Notification must be enabled for your device group to keep your files in sync for recovery purposes.
• You need a working knowledge of Microsoft SQL backup and restore processes before you can use DRMSS.

Installing the Software
Installation of Database Recovery for Microsoft SQL Server (DRMSS) requires the following conditions:
• Before you install DRMSS, you must install Promise SAN Disk Manager (SDM/IMA) on the same machine. If SDM/IMA is not 

detected when DRMSS installation begins, installation stops and displays an error message. Cancel the procedure, install 
SDM/IMA, and then repeat recovery agent installation.

• You must be an administrator or have administrator privileges in order to install and run DRMSS.
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To install DRMSS:
1. Launch the installation from the software DVD.
2. Read and accept the license agreement.
3. Enter your user name and the name of your company.
4. Click the Next button to accept the default installation destination folder or browse to install to a different folder.
5. When prompted, enter your license key code.

The license must be registered with Promise.
• If your computer has an Internet connection, the license is activated as soon as you enter your key code and click the 

Next button. 
• If your Internet connection is temporarily down, your license activates automatically the next time DRMSS is started and 

your Internet connection is working.
• If your computer has no Internet connection, you must perform an offline activation. See the VTrak S3000 Setup Guide 

for more information.
You have 30 days activate your license so that you can continue to use DRMSS.

6. When you are done, click the Finish button.

Using the Console
You can access the Database Recovery for Microsoft SQL (DRMSS) Console:
• As a standalone application
• From Computer Management

To run the console as a standalone application:
Go to Start > Programs > Promise > Database Recovery for Microsoft SQL.
An application window similar to the following appears:
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To access the console via Computer Management console:
Click Administrative Tools > Computer Management, expand the Storage node in the left navigation pane, and click the 
Database Recovery for Microsoft SQL node.

The DRMSS Console is divided into two panes. The left pane contains a navigation Tree with nodes that you can click, expand, or 
collapse. The root node is the Database Recovery for Microsoft SQL node. When you highlight a node in the Tree, the right pane 
displays associated information. For example, when you highlight the Storage Servers node, the right pane displays information 
about your storage servers.

Using the Menus
If you display the Console through Computer Management, the menus at the top of the application window provide access to 
several functions that are common to all Microsoft Management Console-based applications, such as exiting the application. The 
common functions are available via the File, Action, View, Window, and Help menus.

Functions that are specific to DRMSS typically appear in the Action menu. The Action menu is context-sensitive, the objects that 
appear here change, depending on which node is highlighted. For example, when you click the Storage Servers node, the Action 
menu displays. You can also right-click the elements on the screen access DRMSS functions.

Adding and Connecting Storage Servers
The first time you start the application, the system scans and imports all storage servers identified by the IMA Client. These 
storage servers are listed in the Database Recovery for Microsoft SQL (DRMSS) console. After your first backup, all backed up 
databases are listed.

If you add a storage server directly in IMA, it is imported into DRMSS the next time you click the Storage Servers node.

If you add a server directly in DRMSS, the server appears in both IMA and in DRMSS.

If a server is displayed with a red line, the server could be missing credentials or it could be offline. Check the Status field for more 
information.

If the server is missing credentials, add the credentials on the server’s Properties page. For more information, see “Modifying 
Storage Server Properties” on page 23.

Adding a Storage Server
If you do not see your storage server displayed in the Servers list, you must add the server.

To add a server:
1. From the main menu, select Action > New Storage Server. 

Alternately, right-click Storage Servers and select New Storage Server from the popup menu.
The Add Server screen displays.

Note

If you are running the 32-bit version of DRMSS on a 64-bit machine, this method is not available.
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2. Enter the following parameters:
• Server name – Enter the IP address or name (if resolvable) of the storage server.
• Windows Domain Authentication – For iSCSI Storage Servers. Check the box if you are using Windows domain 

authentication. Enter the domain name.
• User name – Enter the user name that has administrative rights to the Storage Server Console.
• Password – Enter the password that goes with the User name.
• Protocols – Check the box beside the protocols your DRMSS client uses. Select at least one.

3. If necessary, click the Advanced button for additional settings.
• iSCSI Advanced Settings – By default, the first detected iSCSI HBA communicates with the storage server. If no HBA is 

detected, the Microsoft iSCSI Initiator is used. You can change the setting here. 
You can also specify the target portal IP address and port number to use for communicating with the storage server.

• Fibre Channel Advanced Settings – By default, your storage server target ports and client initiator ports are set in an 
all-to-all configuration. If you want to use a specific client initiator port, select Enable specific Fibre Channel WWPN 
setting, click Add, type the appropriate WWPN, and click OK.
You must also do this if the system does not automatically detect your HBAs.

4. If your storage server has two or more target ports and you want to use a specific target port, make the setting through the 
storage server console.

5. When you are done, click the OK button. 
After the new server is added, click Refresh to update the Servers list.

Deleting a Storage Server
You can delete a storage server that is no longer in use.

To delete a storage server:
Right-click the storage server and select Delete Storage Server.
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Modifying Storage Server Properties
You only need to modify storage server properties if:
• A server displays with a red line through it
• The server status displays No credentials

To modify storage server properties:
1. Right-click the server name and select Properties.

The Storage Server properties screen displays.

The General tab displays the server name, IP address, storage server software, protocol, connection status, and number of 
databases contained, as well as the last successful and failed snapshot date and time.

The Authentication tab allows you to add credentials or authenticate using your user name and password.

2. If your server displays with a red line through it, click the Resolve button to resolve the host name.
If the host name cannot be resolved, type in the IP address and check the Connect by Address box.

3. If your server’s status displays No Credentials, select the Authentication tab and right-click the unauthenticated server and 
select Properties.
The server properties screen displays.
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4. Enter a user name and password in the fields provided.
For iSCSI Storage server, connect as your regular Windows administrative user. 

5. When you are done, click the OK button.

Configuration
To benefit from all of the features provided with this Database Recovery for Microsoft SQL (DRMSS), at least one of your 
databases should be configured for the Full Recovery Model.

Performing full database backups along with transaction log backups allows you to:
• Restore the database from the most recent full backup
• Apply all the transaction log backups taken since the last full backup

This strategy is good for frequently modified databases and for those where you need to recover data more frequently than the 
interval between full backups. This backup strategy also allows you to restore to a point-in-time before the end of the last 
transaction log backup.

Configuring Global Settings
The global system settings specify the transaction log backup policy and when to purge the event history. 

To configure global settings:
1. From the main menu select Action > Global Settings. 

Alternately, right-click any node in the Tree and select Global Settings.
The Recover Global Settings screen displays allowing you to configure your transaction log backup and purge policy settings 
as well as specify your log settings.

2. Set your Transaction Log Backups preferences using the parameters described below:
• Show transaction log list in the restore wizard dialogs – Allows you to add more detail to the restore wizard. If 

selected, a list of transaction logs is displayed during the restore process.
• Perform a transaction log backup for every snapshot – Backing up the database and the transaction logs is the most 

commonly used backup strategy because it offers a more granular and flexible recovery. This option is selected by 
default to perform a transaction log backup for every snapshot, creating a record of any database changes since the last 
full backup. 

• Truncate transaction logs after they are backed up – Since the log files do use disk space if they are not removed by 
an administrator, you can select to truncate the transaction log files after you have completed the backup of all log files. 
You can configure the snapshot agent to back up the current transaction log using this option.
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• Purge Policy – Allows you to specify the database transaction log purge policy. The selected purge policy options are 
applied immediately and are,
• Purge when there are more than ___ transaction logs per database
• Purge when transaction logs are older than ___ days.

3. Configure your user log settings using the Log Settings tab.
Errors and informational events are in the Computer Management console event viewer. 
Other events are in the program installation directory, RecMSSQL.log file.
The available settings are:
• Off – Only Actions are recorded to the log. This is the default setting.
• Low – Only Actions and Errors are recorded in the log.
• Medium – Actions, Errors, and Warnings are recorded in the log.
• High – Actions, Errors, Warnings, and Informational messages are recorded
• Trace – All messages are recorded in the log.

The Trace log is a diagnostic tool used by your Technical Support team to help solve system problems. Trace logs contain 
technical information about your system and system messages. 
Your Technical Support representative might ask you to turn on the Trace log if you encounter a problem. The trace log file is 
located in the program installation directory.
Trace log settings can be set to:
• Off – No logging.
• Low – Only Errors are recorded in the log.
• Medium – Errors and Warnings are recorded in the log.
• High – Errors, Warnings, and informational messages are recorded. 
• Trace – All messages are recorded in the log.

Configuring the Snapshot Agent for Microsoft SQL Server
The Snapshot Agent for Microsoft SQL Server protects your Microsoft SQL Server database with full point-in-time consistency 
while allowing full speed, continuous access to the database.

To configure database options for the Snapshot Agent for Microsoft SQL Server:
1. From the main menu, navigate to Programs > Promise > Tools > Snapshot Agent for Microsoft SQL Server.

Notes

• If your transaction log backups go to a storage server-managed disk, a copy of the transaction log 
backups is maintained in the storage server. 

• Your backups should take less than eight minutes. Due to the default timeout for your storage server, 
the Snapshot could fail if the backup takes longer.

• If you have scheduled transaction log backups, modify your purge settings accordingly. For example, if 
you have scheduled hourly transaction log backups and a full backup once a day, keep 24 transaction 
log backups or at least one day’s worth of transaction log backups.
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2. Set the following parameters on the Database Options tab,
• Database – Select the database you are protecting.
• Database directory – The location of the database displays here.
• Transaction log directory – The location of the transaction log directory displays here.
• Storage server – The storage server name displays here.
• Transaction log backup directory – Select or browse to locate the transaction log backup directory. By default the 

transaction log directory is used. Promise recommends that you use a separate disk to back up transaction logs.
• Transaction log backup directory – The agent can be configured to perform a transaction log backup - before the full 

snapshot backup. For information, see “Configuring Global Settings” on page 24.

Database Recovery
After a database has crashed it is recommended that you initiate one last Transaction Log backup manually to capture the last 
possible moment before database crashed. Once your backups are in order, there are two restore scenarios to choose from:
• SnapshotView – Restores the database image to a temporary location for validation prior to permanent rollback.
• Snapshot Rollback – Restores a database image (snapshot) to the original location, permanently replacing the existing data.

Restoring a Database
To restore your Microsoft SQL database:
1. Right-click the database you plan to recover and select Restore from the popup menu.

The login screen displays.
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2. Select the database name, storage server, and hostname and click the Next button.
The devices are scanned and the Restore Database - Mode screen displays.

3. Select the restore mode.
• SnapshotView Restore – Temporarily restores a database to a temporary device so you can verify the recovery data 

before committing to a rollback. 
Promise recommends that you use this option first.

• Rollback Snapshot Restore – Permanently restores back to a previous state. Snapshot rollback replaces existing data 
with the selected restore data. 
Promise recommends that you use the SnapshotView Restore option first to determine if the database can be restored 
to a good point-in-time.

4. Select any additional databases to restore.
Promise recommends that you restore all databases on the device. Selecting all databases on the device results in a quick 
disk swap. Otherwise, the system performs a file copy of the selected databases back to the original device when in rollback 
mode. 

5. Select the restore method.
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You can choose from the following types of restore:
• Restore Full backup with transaction logs to a specific point-in-time.
• Restore Full backup from a Snapshot (Advanced option).

The Advanced - Restore option allows you to restore a full backup from a snapshot image. You select the snapshot 
image from the list of available Full Backups.
Check the Restore to the time of the last scheduled transaction log backup box to include all transaction logs.
If you are using a different recovery tool to complete the restore, check the Use “No Recovery” option to keep the 
database in restore mode box.

6. If you selected to restore a full backup with transaction logs to a specific point in time, select the date and time for the restore.
The Restore Database screen displays the full backup and a list of transaction log backups for the recovery. 

This screen only displays if the Show transaction log list in restore wizard dialog setting is selected in the Global Settings. See 
“Configuring Global Settings” on page 24.

7. As needed, modify the list using the Add, Delete, and Move buttons. 
To include transaction logs not taken by this recovery tool, click the Add button and browse for the transaction logs to include 
with the recovery. 
If you have selected multiple databases, verify the list for each database.

8. When you are ready to begin the restore process, click the Next button.
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• If you selected the Rollback Snapshot Restore option in step 3, your data is restored to a previous state in its original 
location.
The restoration process is done. 

• If you selected the SnapshotView Restore option in step 3, the temporary restore process begins and the data is 
restored to a temporary location.
• Verify the recovery data.
• Click the Next button to revert back. Or click the Cancel button to leave the devices in their current state.
• When the recovery data is verified, repeat the process but select the Rollback Snapshot Restore option to 

permanently restore the database.
The data is restored to the original location.
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Promise Recovery Agent for Microsoft Volume Shadow Copy Service (VSS) enables IT administrators to restore volumes and 
volume groups from point-in-time snapshots created by the Snapshot Agent for Microsoft VSS. The Microsoft Management 
Console-based user interface provides the ability to restore complete volumes or groups or narrow the restore to individual 
components. 

About Microsoft VSS
Microsoft VSS provides the backup infrastructure for Microsoft Windows operating systems, using a set of extensible application 
programming interfaces (APIs) to create consistent point-in-time copies of data, or shadow copies, across multiple volumes, 
regardless of the snapshot technology or application, by coordinating with business applications, filesystem services, backup 
applications, fast recovery solutions, and storage hardware. 

VSS consists of four components:
• Requestors – Start the VSS backup or restore operation and manage metadata.
• Writers – Prepare applications for backups and restores.
• Hardware Providers – Create the snapshot shadow copies by communicating with hardware.
• VSS Service – Windows service that controls VSS operations by coordinating the other components.

About the Promise Recovery Agent for VSS
In order to recover the snapshots created by the Promise Snapshot Agent for VSS, use the Promise Recovery Agent for VSS to 
start the recovery process and coordinate recovery with VTrak S3000 Server.

The Recovery Agent for VSS has its own requestor, which exports functions for snapshot recovery.

Terminology
A snapshot is a consistent point-in-time, “frozen” image of one or more data volumes. A quiescent snapshot is one that used 
snapshot notification. With snapshot notification, the system notifies the host to quiet disk activity before the snapshot is taken.

Snapshot
A Snapshot is a point-in-time image of any virtual disk or data volume. It is the result of taking a snapshot. Using Promise's 
Snapshot technology, Snapshots track multiple virtual images of the same disk marked by time. If you need to retrieve a deleted 
file or undo data corruption, you can recreate or restore the file using a Snapshot. Each Snapshot represents one backup image. 

SnapshotView
A SnapshotView is a mountable Snapshot. It allows you to access files and directories by mounting a virtual drive as of a specific 
point-in-time, based on existing Snapshots. 
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System Requirements
Snapshots for the LUN or snapshot group must be enabled in the S3000 server. For more information, see the VTrak S3000 
Server User Manual.

Installing Recovery Agent for VSS
The Recovery Agent for VSS requires the following prior to installation:
• Before you install the Recovery Agent for VSS, you must install Promise SAN Disk Manager (SDM/IMA) on the same 

machine. If SDM/IMA is not detected when recovery agent installation begins, installation stops and displays an error 
message. Cancel the procedure, install SDM/IMA, and then repeat recovery agent installation.

• Approximately 50 MB hard disk space are needed for history and log files.
• You must be an administrator or have administrator privileges in order to install and run Recovery Agent for VSS.

To install Recovery Agent for VSS:
1. Launch installation from the software DVD.
2. Read and accept the license agreement.
3. Enter your user name and the name of your company.
4. Click the Next button to accept the default installation destination folder or browse to install to a different folder.
5. When prompted, enter your license key code.

The license must be registered with Promise.
• If your computer has an Internet connection, the license is activated as soon as you enter your key code and click the 

Next button. 
• If your Internet connection is temporarily down, your license activates automatically the next time DRMSS is started and 

your Internet connection is working.
• If your computer has no Internet connection, you must perform an offline activation. See the VTrak S3000 Setup Guide 

for more information.
You have 30 days activate your license so that you can continue to use DRMSS.

6. When you are done, click the Finish button.
By default, the agent is installed to Start > All Programs > SANClient > VSSRecover.
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Recovery Agent Management Console
To run the console as a standalone application, go to Start > All Programs > SANClient > Recovery Agent for VSS.

You can also access the console via the Computer Management Console:

Click Control Panel > Administrative Tools > Computer Management.

Expand the Storage node in the left navigation pane and click the Recovery Agent for VSS node.

An application window similar to the following appears.

The console is divided into two panes. The left pane contains a navigation tree with nodes that you can click, expand, or collapse. 
The root node is the Recovery Agent for VSS node. When you highlight a node in the navigation tree, the right pane displays 
associated information. For example, when you highlight the Storage Servers node, the right pane displays information and status 
about your storage servers.

Menus
If you display the Console through Computer Management, the menus at the top of the application window provide access to 
several functions that are common to all Microsoft Management Console-based applications, such as exiting the application. The 
common functions are available via the File, Action, View, Window, and Help menus.

Functions that are specific to Recovery Agent for VSS appear in the Action menu. The Action menu is context-sensitive, the 
objects that appear here change, depending on which node is highlighted. For example, when you click the Storage Servers 
node, the Action menu displays. You can also right-click the elements on the screen access Recovery Agent for VSS functions.

Note

If you are running the 32-bit version of Recovery Agent for VSS on a 64-bit machine, this method is not 
available.
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Objects in the Console Navigation Tree
The Volumes and Groups object lists all of the volumes and groups that are on VTrak S3000 Server-provisioned storage.

If a volume has a status of Volume Missing, delete the volume. This action also deletes events associated with the volume.

To delete a volume:
1. Right-click the volume and select Delete Volume from the popup menu.
2. In the confirmation dialog box, click the Yes button to confirm.

Volume Groups
Highlighting the Volume Groups object displays a list of all the volumes that are on a particular snapshot group, showing group-
specific information such as the name of the group, the number of volumes and their labels, the storage server on which those 
volumes reside, the date and time of last backup, and volume group status.

Volume Group Properties
Details for each volume group are available on the property pages. 

To view volume group properties:
Right-click a volume group and select Properties from the popup menu.
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The General tab shows storage server and group information.

The Devices tab shows a list of each device in the group, with the properties that were previously set for each device.
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The Mount Points tab lists all of the mount points for volumes in the group.

The Statistics tab shows statistics for backups or snapshot creation, and restores for the group, based on the history.
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The History tab lists the backup and restore events recorded for the volumes in the group.

Volumes
Highlighting the Volumes object lists individual volumes and volume-specific information.

Volume properties
Details for each volume are available on the property pages.

To view volume properties:
Right-click a volume and select Properties from the popup menu.
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The General tab shows summary information for the selected volume.

The remaining tabs show information that is similar to the information shown for volume groups. See pages 35 through 37.

Storage Servers
The Storage Server node lists all available storage servers and general information for each server as shown below.

From this node, you can add and remove storage servers. See “Adding and Connecting Storage Servers” on page 41.

The entry for each server lists all volumes and volume groups that belong to that server. 

Storage Server Properties
Details for each storage server are available on the property pages.

To view storage server properties:
Right-click a storage server and select Properties from the popup menu.

The General tab lets you connect to the server by address or server name, resolve the server name, and change the address. 
For more information, see “Adding Credentials for a Storage Server” on page 43 and “Resolving the Storage Server Host 
Name” on page 42.
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The Authentication tab allows you to provide credentials for a recovery agent administrator. These credentials are required to 
perform a recovery. See “Adding Credentials for a Storage Server” on page 43. Or define an administrator from the server. 
See “System Requirements” on page 32.

The Statistics tab shows statistics for backups or snapshot creation, and restores for the storage server, based on the history.

The History tab lists the backup and restore events recorded for the volumes and volume groups on the selected storage 
server.

Events
Highlighting the Events node displays a list of all events related to backups and restores that have occurred on all volumes. If the 
Snapshot Agent for VSS is also installed, all events are also sent to the Windows Event Log.

Icon color indicates event status:
• Blue – Informational
• Yellow – Warning
• Red – Error

Sorting Events
To sort the events in alphabetical/numerical order:

Click the heading of the appropriate column. 
Click again to reverse the order.
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Searching for Events
To search for a specific event or a range of events:
1. Select the search criteria in the first drop-down box.
2. Type all or part of the item you want in the search field and click the Go button.

The search function is case sensitive. Only the events matching your criteria display.
3. When you are finished, click the Clear Filter button.

Global Settings
Global system settings are used to specify where to store important directories and when to purge event history. Configure your 
global settings to specify where to store your scripts. You can also specify your default mount directory and indicate your preferred 
purge policy.

Making Global Settings
To make global settings:
1. Right-click any of the main nodes and select Global Settings from the popup menu.

You can also select Global Settings from the Action menu. 
2. Use the Mount Directory tab to specify where the default directory is mounted for the VSS recovery agent.

3. Select the Purge Policy tab to specify the purge policy for Event history.

The selected purge policy options are applied immediately and are as follows:
• Purge when there are more than ___ events per script. The default is 60.
• Purge when events are older than ___ days. The default is 30. 

Set this field to zero to ignore this option.
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Adding and Connecting Storage Servers
The first time you start the application, the system scans and imports all storage servers identified by the IMA Client and lists them 
in the console.

Adding a Storage Server
If you do not see your storage server displayed in the Storage Servers list, you can manually add it. Adding a server here or 
through SDM registers the server with IMA.

To add a storage server:
1. In the directory tree, right-click the Storage Servers node and select New Storage Server from the popup menu.

Alternatively, select Action > New Storage Server from the main menu.
The Add Server dialog displays.

2. Enter the following parameters:
• Server name – Enter the IP address or name (if resolvable) of the storage server.
• User name – Enter the user name that you created for the recovery agent in the Promise Management Console.
• Password – Enter the password that you created for the recovery agent in the Promise Management Console.
• Protocols – Select which protocols your recovery agent client uses. You must select at least one. 

3. If necessary, click the Advanced button next to a protocol for additional settings.
• iSCSI Advanced Settings – By default, the first detected iSCSI HBA communicates with the storage server. If no HBA is 

detected, the Microsoft iSCSI Initiator is used. Change the setting as needed.
Specify the target portal IP address and port number to use for communicating with the storage server.

• Fibre Channel Advanced Settings – By default, your storage server target ports and client initiator ports are set in an 
all-to-all configuration. If you want to use a specific client initiator port, select Enable specific Fibre Channel WWPN 
setting, click Add, type the appropriate WWPN, and click OK.
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You must also do this if the system does not automatically detect your HBAs.

4. If your storage server has two or more target ports and you want to use a specific target port, make this setting in the Promise 
Management Console.

5. When you are done, click the OK button.
After the new server is added, click Refresh to update the Servers list.

Resolving the Storage Server Host Name
If a server is displayed with a red line through it, you need either to resolve the hostname in order to bring the server online or 
supply missing credentials. The procedure for resolving the host name is below; refer to Add credentials for a storage server if you 
need to supply credentials. You can do either in the Server Properties dialog box.

1. Right-click the server name and select Properties from the popup menu.
The storage server Properties dialog box displays.
The General tab displays the server name, IP address, storage server software, protocol, the number of volumes, and 
connection status.

2. To resolve the host name, confirm the IP address or enter a new IP address and click the Resolve button.
To connect using the IP address instead of the host name, check the Connect by Address box.

3. Click the OK button.
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Adding Credentials for a Storage Server
If a server is displayed with a red line through it, the server may be missing credentials or may be offline. This can occur if the 
server was added via IMA. If the server is offline, refer to Resolve the storage server host name to bring it online. 

If the Status field displays No Credentials, you must supply the missing credentials.

To add credentials for a storage server
1. Right-click the unauthenticated server and select Properties from the popup menu.

The server Properties dialog box displays.
2. Select the Authentication tab.
3. Enter a user name and password to log into the storage server

4. Click the OK button.

Deleting a Storage Server
You can delete a storage server that is no longer in use.

To delete a storage server:
1. In the Recovery Agent for VSS console, right-click the storage server and select Delete Storage Server from the popup 

menu.
2. Click the OK button to confirm.

Recovery
The Microsoft Management Console-based console for the Promise Recovery Agent for VSS allows you to restore from point-in-
time snapshots created using the Snapshot Agent for VSS. You can pick volumes or volume groups to restore, as well as view 
their backup and restore history.

Supported Writers
The Recovery Agent for VSS is designed to make restores uniform across applications; however, each writer has distinct 
behaviors, the most important of which are noted below. 

Microsoft Exchange 2010 and 2007
The New Target option is supported but you cannot move a database to a new location. However, if the backup contained a 
database in one directory but it has subsequently been moved, the specify the new or current location of the database.
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If you are performing a recovery from a different host’s devices, such as Continuous Cluster Replication (CCR), change the 
directory. The agent automatically copies all log and env files to a new directory before starting the restore, ensuring that old logs 
do not prevent a successful recovery.

Microsoft SQL 2008
SQL automatically dismounts databases during restores, except for system databases. The SQL writer supports New Target and 
allows you to move a database to a new location. If you specify a new location for the database and log files, SQL uses the 
database in the new location in the future.

Microsoft Hyper-V
Virtual machines selected for restore are automatically turned off and removed. New Target is not supported.

Microsoft Active Directory 2008 and 2008 R2
Supported.

Using the Recovery Wizard
To start the recovery wizard from the console:
1. Right-click a volume or volume group and select Restore Volume or Restore Volume Group.
2. Choose a recovery method.

• File Copy – Copy files from the snapshot back to the original volume, similar to traditional backup software. Security 
settings for the files are preserved. The SnapshotView source (a device or group) is selected automatically.
• Manually select devices – If you select File Copy, you can also choose to manually select the device or group as 

the source of SnapshotViews.
• Rollback – The device or group is automatically selected. Rollback is based on SnapshotView data. Rollback changes 

the disk signature to the SnapshotView signature. After rollback, the recovery agent restores the original disk signature.
Rollback has limitations:
• Rollback does not support the New Target option. You cannot specify a different restore path.
• Replication policies must be suspended during rollback. If you do not suspend replication before doing a rollback, 

the recovery agent suspends replication for the duration of the rollback.
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3. Select a Snapshot to be used for recovery.

Each Snapshot entry includes the following information:
• Storage Server – The server on which the Snapshot is located.
• Volume – The volume/volume group you selected in the recovery agent console.
• Date – the date the Snapshot was created.
• Comment – When you create a Snapshot manually, you have the opportunity to include a comment.
• SnapshotView – Persisted means that the Snapshot has SnapshotView data. None means there no SnapshotView data. 

Mounted means the SnapshotView is active. 
You can use only those Snapshots that have SnapshotView data. 

• Status – This column indicates whether the Snapshot is quiescent.
After you select a Snapshot, the status screen displays and the SnapshotView is assigned and mounted. For more 
information, see “Viewing Recovery Status” on page 46.

4. If you selected the Manually select devices option, select a remote device from which to restore a Snapshot.

The next dialog box lists the Snapshots available on that device. Select the Snapshot to be used for recovery.
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This step allows you to restore from a Snapshot on a different device than the default. For example, in Exchange CCR, the 
same data is stored on independent storage. You can take snapshots on the passive Exchange node and then manually 
select the passive node’s storage during restore of the primary Exchange node.

5. Select the VSS components that you want to restore.

The list of available writers, components, and files is generated from the metadata saved to the SnapshotViews and from the 
writers currently available on the host. 
Some of these writers support the New Target option, which allows the files to be restored to a different location,. For more 
information, see “Supported Writers” on page 43. If a writer supports this option and you did NOT select the Rollback mode, 
select each file you want to restore and change its target path.
If no writers are available for restore, this screen is not displayed.
Click the Back button to change options. Or click the NEXT button to continue. 
The Summary dialog box displays the Snapshot and VSS component options you selected.

6. Click the Finish button begin recovery.
When recovery is complete, the status display shows Restore completed successfully.

Viewing Recovery Status
A Status dialog box displays when SnapshotViews are being assigned or unassigned and during the restore operation. A typical 
status window is shown below.

The icon color indicates the state of each recovery action:
• Grey – Not started
• Blue – In progress
• Green – Success
• Red – Failure
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Event Logging
Two levels of logging are provided for the Recovery Agent for VSS:
• Host application log
• Microsoft Application Event log

The default path of the host application log is Program Files/Promise/VSSRecover/Log.
The Microsoft Application Event Log is listed as Recovery Agent.
For more information on displaying event history in the recovery agent console, see “Events” on page 39.

Diagnostic X-Ray
The Recovery Agent for VSS supports a diagnostic feature that allows you to collect information from the host into a file that can 
be sent to technical support. 

To create a diagnostic X-ray file:
1. Right-click the root node in the console and select Take X-ray from the popup menu.
2. In the X-ray dialog box, the default path and X-ray filename are shown.

You can specify a different filename or browse to a different location where you want the X-ray file to be created.

3. When you are done, click the Finish button.
The X-ray takes several minutes to complete.
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