Promise Knowledge Base

Expand / Collapse

WebPAM Troubleshooting

Expand / Collapse
Last Modified:Sunday, March 04, 2007

WebPAM Troubleshooting


These are some issues that have been reported when using WebPAM 1.7 and Vtrak 12110

Solution:

1. WebPAM Promise 12110

The new WebPAM look and feel is improved. But adding a 12110 unit takes a long time – 10-15 minutes.

The time that adding a subsystem will take depends on different situations. Usually it takes about 3-4 minutes. If there is network problem then some latency is expected for connection to the subsystem. If WebPAM is adding a subsystem immediately after subsystem reboot, then WebPAM PRO may not be able to access the software components (embedded in subsystem) such as MOF and Java Native Interface, which may not be fully loaded yet. It is suggested that user waits 2-3 minutes before adding subsystem into WebPAM PRO after system reboot.

2. Promise 12110 Administrator

After 12110 system reboot, start WebPAM and login as Administrator.

The menu bar on the left takes a long time to load.

If the subsystem is turned off and WebPAM PRO is restarted, then

WebPAM PRO will still try to connect the subsystem after it is restarted. It will take some time to timeout because there will be no data returned from the subsystem. WebPAM PRO eventually will show a red subsystem icon (in the left tree with no data in it) to indicate the subsystem is not accessible.

If the subsystem is rebooted (and the subsystem has been already added)

WebPAM PRO checks every 20 minutes for the availability of the subsystem. If it detects the subsystem again, it will update its internal cache for the components such as Controller, Disk, DA, LD, etc., which is time consuming.

If the host PC (where the WebPAM PRO is installed) is rebooted

If the user immediately tries to log into WebPAM PRO, it will take a while for the left frame to show up. It is because during reboot, WebPAM PRO will try to connect to all available subsystems according to its internal database and get all the data for different component such as Disk, Controller, DA, LD etc. It will take a while to get the data from each subsystem and update its local cache. Left frame will not be seen until the cache is updated completed.

3. Promise 12110 WebPAM Administrator

Vtrak 12110 Promise 12110

After 12110 system reboot, start WebPAM and login as Administrator. The left menu bar IP -> VTrak 12110 -> Enclosure View shows an exclamation mark. The content of this item cannot be displayed even after system reboot. The right panel shows "Cannot find subsystem (or "enclosure"?).

We cannot reproduce the problem in the lab. Left Frame and enclosure page works just fine. This issue may be because the subsystem is being rebooted and WebPAM PRO is trying to connect to it at the same time. It can be fixed by removing and then adding the subsystem.

4. Promise 12110 Promise 12110 Raid WebPAM Promise 12110

Install WebPAM on two host systems. Add 12110 to both. But the information displayed from the two systems are different. One shows the 12110 with HDD info and RAID info. But the other cannot display (any RAID or HDD info), even though the system can see the 12110 unit.

Although we do not recommend multiple (or two) WebPAM PRO, technically speaking it can handle this scenario. We installed WebPAM PRO on two different hosts Windows 2003 SP1 and Windows 2000 advanced server. Either WebPAM PRO is able to see the same VTrak 12110 (SR5) with correct RAID information.

5. WebPAM

This one seems to be a question or a suggestion for improvement. Can you add the subsystem re-insertion status in the menu on the left? (I’m not certain if I captured this one correctly.)

WebPAM PRO provides an Update All button to refresh all data for each subsystem. The Update All button is located in the Subsystem Information page, which can be accessed by clicking the Subsystem (e.g., VTrak 12110) icon.



Add Your Comments and Ratings


Name: *
Email Address: *
Verification Code:
*
Select a rating